aboutsummaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorJames Magahern <james@magahern.com>2019-01-18 11:14:20 -0800
committerJames Magahern <james@magahern.com>2019-01-18 11:14:20 -0800
commitc78f8de38f77a65555e3241ede496da603017afd (patch)
tree9a5007609f924aa8f33baaa334d0bb62856af515 /meson.build
parentgitignore (diff)
Move to meson build system. very cool
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build31
1 files changed, 31 insertions, 0 deletions
diff --git a/meson.build b/meson.build
new file mode 100644
index 0000000..0f79608
--- /dev/null
+++ b/meson.build
@@ -0,0 +1,31 @@
+project('buzzlocker', 'c')
+
+sources = [
+ 'src/main.c'
+]
+
+dependencies = [
+ dependency('x11'),
+ dependency('cairo'),
+ dependency('librsvg-2.0'),
+ dependency('pangocairo')
+]
+
+executable('buzzlocker',
+ sources: sources,
+ dependencies: dependencies
+)
+
+# Resources
+configure_file(
+ input: 'resources/logo.svg',
+ output: 'logo.svg',
+ copy: true
+)
+
+configure_file(
+ input: 'resources/asterisk.svg',
+ output: 'asterisk.svg',
+ copy: true
+)
+