aboutsummaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py36
1 files changed, 36 insertions, 0 deletions
diff --git a/setup.py b/setup.py
new file mode 100644
index 0000000..605be63
--- /dev/null
+++ b/setup.py
@@ -0,0 +1,36 @@
+#!/usr/bin/python
+# -*-coding:utf-8 -*
+
+from setuptools import setup, find_packages
+
+
+import libkyf
+
+
+setup(
+ name='libkyf',
+ version=libkyf.__version__,
+
+ description='A parser for KYF',
+ long_description=open('README.md').read(),
+ author='Hédy Ache',
+ author_email='ache@ache.one',
+ url='http://git.ache.one/kyf',
+ license='GNU GPL v3',
+# install_requires=[],
+# zip_safe=False,
+
+ include_package_data=True,
+
+ packages=find_packages(),
+ classifiers=[
+ "Programming Language :: Python",
+ "Development Status :: 1 - Planning",
+ "Natural Language :: French",
+ "Operating System :: OS Independent",
+ "Programming Language :: Python :: 2.7",
+ "Programming Language :: Python :: 3.5",
+ ]
+
+
+)